2011年3月1日星期二

Re: Site Redirecting

Thanks, that helps. I will try to see if I can track that down somewhere. Just in case it maybe something else, below is my conf.



server {
            listen   80;
            server_name _ classblogs.us *.classblogs.us;
            access_log /home/parkerj/public_html/classblogs.us/log/access.log;
            error_log /home/parkerj/public_html/classblogs.us/log/error.log;

            # Set this to off if you're hosting more than one site
            server_name_in_redirect off;

            location ~* ^.+\.(xml|jpg|jpeg|gif|png|ico|css|zip|tgz|gz|rar|bz2|doc|xls|pdf|ppt|txt|tar|mid|midi|wav|bmp|rtf|js|swf|m$
            root        /home/parkerj/public_html/classblogs.us/public;
            # rewrite rules
            #rewrite ^/.*(/wp-.*/.*\.(xml|jpg|jpeg|gif|png|ico|css|zip|tgz|gz|rar|bz2|doc|xls|pdf|ppt|txt|tar|mid|midi|wav|bmp|rtf|$
            rewrite ^.*/files(/.*)$ /wp-includes/ms-files.php?file=$1 last;
            expires 10d;
            break;
            #error_page 404 = @wordpress;
            #log_not_found off;
      }


            location /  {

            try_files $uri $uri/ @wordpress;

            gzip on;
            gzip_http_version 1.0;
            gzip_vary on;
            gzip_comp_level 3;
            gzip_proxied any;
            gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss t$
            gzip_buffers 16 8k;

            root   /home/parkerj/public_html/classblogs.us/public;
            index  index.php;

            client_max_body_size        10M;
            client_body_buffer_size     128K;

            if (!-e $request_filename) {
              #rewrite ^/.*(/wp-(content|includes|admin).*)$ $1 last;
              rewrite ^(.+)$ /index.php?q=$1 last;
            }
                        }

            location @wordpress {
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_param SCRIPT_FILENAME /home/parkerj/public_html/classblogs.us/public$fastcgi_script_name;
            include /usr/local/nginx/conf/fastcgi_params;
            fastcgi_param SCRIPT_NAME /index.php;
            }

            # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
            location ~ \.php$
                                {
            try_files $uri @wordpress;
            root   /home/parkerj/public_html/classblogs.us/public;
            rewrite ^/.*(/(xmlrpc|wp-(cron|login|comments-post|signup)).php)$ $1 last;
            rewrite ^/.*(/wp-(content|includes|admin).*)$ $1 last;
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_index index.php;
            include /usr/local/nginx/conf/fastcgi_params;
            fastcgi_param SCRIPT_FILENAME /home/parkerj/public_html/classblogs.us/public$fastcgi_script_name;
                        }

            location ^~ /blogs.dir/ {
                internal;
                root /home/parkerj/public_html/classblogs.us/public/wp-content;
            }
       }

On Tue, Mar 1, 2011 at 3:20 PM, Guzman Braso <guzman.braso@gmail.com> wrote:
Also it may be your application & not nginx giving the 302 when users
request /welcome/

At least that /welcome/ comes with a some application headers like
X-Pingback & X-Powered-By.

I would suspect your nginx is working as expected, it's your
application not working correctly when /welcome/ is requested.

As it was said send your config if you need help

On Tue, Mar 1, 2011 at 6:18 PM, Guzman Braso <guzman.braso@gmail.com> wrote:
> Just checked...
>
> From here I see a 302 redirect from the home to /welcome/ together
> with setup of three cookies "PHP_SESSION", "bp-message" &
> "bp-message-type".
> Then /welcome/ gives a 302 to the home, together with set-cookie of
> "bp-message" & "bp-message-type".
>
> And again and again and again and again...
>
>
> On Tue, Mar 1, 2011 at 6:01 PM, Parker, Joshua <josh@joshparker.us> wrote:
>> I should also mention that the main site only redirects when you are *not*
>> logged in.
>>
>>
>> On Tue, Mar 1, 2011 at 3:00 PM, Parker, Joshua <josh@joshparker.us> wrote:
>>>
>>> Hello, everyone. I have Wordpress 3.1 Multisite installed, and my main
>>> site is in a continuous loop: http://classblogs.us/. There is nothing in my
>>> error logs to tell me what is wrong. Can someone help me with
>>> troubleshooting this issue? Thanks.
>>>
>>>
>>> --
>>> Joshua Parker
>>>
>>
>>
>>
>> --
>> Joshua Parker
>> Church Management System - http://www.churchmember.us/
>>
>> _______________________________________________
>> nginx mailing list
>> nginx@nginx.org
>> http://nginx.org/mailman/listinfo/nginx
>>
>>
>
>
>
> --
> Guzmán Brasó Núñez
> Senior Perl Developer / Sysadmin
> Web: http://guzman.braso.info
> Mobile: +598 98 674020
>



--
Guzmán Brasó Núñez
Senior Perl Developer / Sysadmin
Web: http://guzman.braso.info
Mobile: +598 98 674020

_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx



--
Joshua Parker
Church Management System - http://www.churchmember.us/

没有评论:

发表评论