2011年2月17日星期四

Re: Problem with nginx/0.8.54 and alias

Hi Maxim!

Maxim Dounin Wrote:
-------------------------------------------------------
> Hello!
>
> On Thu, Feb 17, 2011 at 01:09:15PM -0500, Dayo
> wrote:
>
> > Igor Sysoev Wrote:
> >
> --------------------------------------------------
> > > Use late 0.8.x with this configuration:
> > >
> > > location ~ ^/phpmyadmin/(?.+\.php)$ {
>
> Just a side note: forum is awful, it eats data.

To be fair to the forum, I was the one that truncated the quote to only
show the relevant part to my post.
The long and complex quotes become impossible for me to follow.

However, I do have a gripe with the forum which is the annoying preview
code that hovers when mousing over links. I am considering using the
Ruby Forum to follow things instead as that preview thing is a major
irritation when using the Nginx Forum and the admin has ignored all
requests to provide an option to switch it off.

>
> > > fastcgi_pass 127.0.0.1:9000;
> > > fastcgi_param SCRIPT_FILENAME
> > >
> > > /var/www/monsite.fr/phpMyAdmin/$NAME;
> > > include fastcgi_params;
> > > }
> > Tried this out on 0.8.54 and got ...
> >
> > pcre_compile() failed: unrecognized character
> after (?< in
> > "^/phpmyadmin/(?.+\.php)$" at "NAME>.+\.php)$"
>
> Probably you have ancient PCRE library. Try (?P)
> form
> which is supported since PCRE 4.0.
>
> http://nginx.org/en/docs/http/server_names.html#re
> gex_names

Thanks for that. The (?P) form works.

Posted at Nginx Forum: http://forum.nginx.org/read.php?2,176110,176387#msg-176387


_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx

没有评论:

发表评论