2011年2月15日星期二

Re: Install problem using .deb package

António P. P. Almeida Wrote:
-------------------------------------------------------
> On 16 Fev 2011 01h25 WET, nginx-forum@nginx.us
> wrote:
>
> > Hi,
> >
> > I'm trying to install nginx 0.8.54 on Debian
> Squeeze. It builds
> > successfully, and I've created a .deb package
> using checkinstall.
> >
> > However when I try to install the package I run
> into an error:
> >
> >
[code]
> > # dpkg -i nginx_90.8.54-1_i386.deb
> > (Reading database ... 38153 files and
> directories currently
> > installed.) Unpacking nginx (from
> nginx_90.8.54-1_i386.deb) ...
> > dpkg: error processing nginx_90.8.54-1_i386.deb
> (--install): unable
> > to create
> `/etc/nginx/uwsgi_params.default.dpkg-new' (while
> > processing `./etc/nginx/uwsgi_params.default'):
> No such file or
> > directory Errors were encountered while
> processing:
> > nginx_90.8.54-1_i386.deb
[/code]
> >
> > It looks like it can't find the file
> > ./etc/nginx/uwsgi_params.default inside the .deb
> > package, but it is there (I gave the package a
> way high version
> > number (90.0.8.54) is so apt won't overwrite
> it):
>
>
> Do you need uwsgi? If so then you must install
> support for it. Can't
> help you there. Remove these modules from the
> build and I venture that
> it will build and install.
>
> You can get my source package:
> http://debian.perusio.net and build it
> in Squeeze. That's for 0.9.4. I've built that
> previously on a mixed
> Lenny/Squeeze.
>
> HTH,
> --- appa
>
>
>
> _______________________________________________
> nginx mailing list
> nginx@nginx.org
> http://nginx.org/mailman/listinfo/nginx


Thanks but I'd prefer to use the current stable version.

Okay well dpkg was correct. It seems I have to manually create all the
directories that nginx will use beforehand, and then it installs fine.
Wonder why the deb package won't do that automatically, as looking at
the makefile, it will create them if they don't exist. Perhaps it's just
something that checkinstall misses when it creates the package....?

Anyhow, it's working now :-)

Thanks,
Gordon

Posted at Nginx Forum: http://forum.nginx.org/read.php?2,175631,175651#msg-175651


_______________________________________________
nginx mailing list
nginx@nginx.org
http://nginx.org/mailman/listinfo/nginx

没有评论:

发表评论